Fedora RPMS for Enlightenment and EFL 1.7.6x

28 Apr

Sorry this one took longer, however it's up on the repo. This is the Enlightenment release and the 1.7.6x of EFL. I have not tested this build, i am going to pull it down to my local machines and see how it goes. I built new Python bindings and all the modules that i had before. I hope i didn't miss any. If so let me know in the comments.


This will be my final build of for Fedora 17. I am planning on upgrading my machine to either 18 or 19 here soon. Yes 19 is not out yet, but the alpha is so i know a release might happen before i get my machine updated. Also i need to purchase a new laptop. Anyway enjoy the build and let me know if you have issues.

UPDATE: Fri May 10 16:41:27 CDT 2013

So i forgot to build enlightenment and then when i did i uploaded it and forgot to update the repo database. Well that has been done. You might need to run a yum clean all. Well "all" is what i have run. I am sure someone will comment to let me know exactly which option i should give yum clean. I hear that the 1.7.7 libs will be out soon. So maybe this weekend i will have a working and good build system.

UPDATE: Sat May  4 08:59:17 CDT 2013

It was reported that eina-1.7.6 was missing. This i found was only for the Fedora 18 x86_64 release. I have fixed that and uploaded the rpm. Hopefully for this release we don't have any more issues.

UPDATE: Mon Apr 29 20:13:39 CDT 2013

I have fixed connman so that it does not Obsolete NetworkManager. Also Macfly reported an issues with eeze. I have fixed that package and uploaded a new version. Enjoy the Enlightenment goodness. Also this is the last version for Fedora 17. I will be doing only Fedora 18 and 19 from now on. I might put 19 up for the 1.7.6 EFL release. I will see how much time i get to devote to the build.

UPDATE: Mon Apr 29 07:25:53 CDT 2013

I am going to rebuild connman and not obsolete NetworkManager. It will cause issues when you try and update. I am sorry about this unforeseen side effect. I will have the rebuilt package up tonight.


Leave a Reply


Allowed XHTML tags: <p, ul, ol, li, dl, dt, dd, address, blockquote, ins, del, span, bdo, br, em, strong, dfn, code,samp, kdb, var, cite, abbr, acronym, q, sub, sup, tt, i, b, big, small>


  1. Macfly

    April 29th 2013 at 02:04 pm

    Hi, I tried your package and i've got 'libudev' unmet dependencies on 'eeze-1.7.6-0'. If you need more information or if you can give me the way to get libudev package. Thanks for your work

    Errors with undefined symbol: eina_seed

    May 1st 2013 at 02:05 am

    Hi, thanks for the builds, but I can't seem to get terminology to work. When I run it I get: terminology: symbol lookup error: /lib64/ undefined symbol: eina_seed Any suggestions? Thanks

    eina-1.7.6 is missing in RPMS

    May 3rd 2013 at 06:05 am

    Looks like issue with undefined symbol eina_seed is due to eina-1.7.6 was not pushed into RPMS directory. Currently there is eina-1.7.6 in SRPMS: when i built and installed it the issue went away.


    May 6th 2013 at 03:05 am

    enlightenment_i[6713]: segfault at 1e4 ip 00007fd385e2ee97 sp 00007fff9a8bf570 error 4 in[7fd385e1300 0+33000] I am getting this segfault on fedora18 64bit [root@hovercraft ~]# rpm -q enlightenment enlightenment-0.17.1-0.enl.fc18.x86_64 so apparantly the latest is missing from repos

    No enlightenment package version for x86_64 architecture?

    May 9th 2013 at 02:05 pm

    Hi, great work - I began using E17 through your repo, before that I have never managed to get it working. Is it possible that there is this version missing for the x86_64 architecture? At least I am unable to find any file like "enlightenment-" in the repo. For the i686 architecture, a counterpart is there.

    No enlightenment package version for x86_64 architecture?

    May 10th 2013 at 05:05 am

    Hi, thanks for your great work! However, one question please: Is it possible that Enlightenment is not included in the F18 repo for the x86_64 architecture? In the i686 tree, I find such an rpm, but not for x86_64 tree.

    eina 1.7.6-0.20130429 conflicts with libeina-1.2.1-1

    May 10th 2013 at 01:05 pm

    When I try to install eina, I get this error: Transaction Check Error: file /usr/lib64/ from install of eina-1.7.6-0.20130429.x86_64 conflicts with file from package libeina-1.2.1-1.fc18.x86_64. If I uninstall libeina, I can install eina, but things still don't work. Either I install eina and get a crash on login where attempts to restart fail and the only option which works is to log out or I install libeina and never get beyond the login screen. Thank you for your work on this. I am really starteing to like Enlightenment E17, and hope it does make it into Fedora 19, but I don't see it in the accepted features list. I'd hate to have to wait until Fedora 20, especially since E17 has been out several months now.

    src rpm

    May 13th 2013 at 01:05 am

    Hello, could you please upload src.rpm for enlightenment- ? has only 0.17.1 version...

    May 13th 2013 at 02:05 am

    Hi, thanks for the rpm , but i have problem . When I run terminology: symbol lookup error: /lib64/ undefined symbol: eina_seed Any suggestions?